problem with init on opensips3.0

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

problem with init on opensips3.0

Johan De Clercq

Hello,

 

Opensips3.0 doesn’t start automatically.    It times out on a remote mysqlconnection.  

 

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:db_mysql:db_mysql_connect: driver error(2003): Can't connect to MySQL server on '10.3.0.81' (110 "Connection timed out")

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:db_mysql:db_mysql_new_connection: initial connect failed

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:db_do_init: could not add connection to the pool

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:domain:domain_db_init: Cannot initialize database connection

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:init_mod: failed to initialize module domain

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:main: error while initializing modules

 

With 2.4, the problem was not there. Please advice on how I need to fix this.

 

 

 

cid:F3100D46-F00D-4610-87ED-3E91DA790A82

Johan De Clercq, Managing Director
Democon bvba - Ooigemstraat 41 - 8780 Oostrozebeke

Tel +3256980990 – GSM +32478720104

 


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

Opensips_init_script.txt (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: problem with init on opensips3.0

Liviu Chircu

Hi Johan,

Just to be 100% sure it's an OpenSIPS problem, can you confirm either:

* the "db_url" credentials work when used with the "mysql" command-line client,
  from the same source IP
* the same "db_url" works with a 2.4 OpenSIPS, from the same source IP

Regards,

Liviu Chircu
OpenSIPS Developer
http://www.opensips-solutions.com
On 22.06.2019 16:43, johan de clercq wrote:

Hello,

 

Opensips3.0 doesn’t start automatically.    It times out on a remote mysqlconnection.  

 

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:db_mysql:db_mysql_connect: driver error(2003): Can't connect to MySQL server on '10.3.0.81' (110 "Connection timed out")

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:db_mysql:db_mysql_new_connection: initial connect failed

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:db_do_init: could not add connection to the pool

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:domain:domain_db_init: Cannot initialize database connection

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:init_mod: failed to initialize module domain

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:main: error while initializing modules

 

With 2.4, the problem was not there. Please advice on how I need to fix this.

 

 

 

cid:F3100D46-F00D-4610-87ED-3E91DA790A82

Johan De Clercq, Managing Director
Democon bvba - Ooigemstraat 41 - 8780 Oostrozebeke

Tel +3256980990 – GSM +32478720104

 


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: problem with init on opensips3.0

Johan De Clercq
Yes, they work form command line.

Op di 25 jun. 2019 om 16:54 schreef Liviu Chircu <[hidden email]>:

Hi Johan,

Just to be 100% sure it's an OpenSIPS problem, can you confirm either:

* the "db_url" credentials work when used with the "mysql" command-line client,
  from the same source IP
* the same "db_url" works with a 2.4 OpenSIPS, from the same source IP

Regards,

Liviu Chircu
OpenSIPS Developer
http://www.opensips-solutions.com
On 22.06.2019 16:43, johan de clercq wrote:

Hello,

 

Opensips3.0 doesn’t start automatically.    It times out on a remote mysqlconnection.  

 

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:db_mysql:db_mysql_connect: driver error(2003): Can't connect to MySQL server on '10.3.0.81' (110 "Connection timed out")

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:db_mysql:db_mysql_new_connection: initial connect failed

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:db_do_init: could not add connection to the pool

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:domain:domain_db_init: Cannot initialize database connection

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:init_mod: failed to initialize module domain

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:main: error while initializing modules

 

With 2.4, the problem was not there. Please advice on how I need to fix this.

 

 

 

cid:F3100D46-F00D-4610-87ED-3E91DA790A82

Johan De Clercq, Managing Director
Democon bvba - Ooigemstraat 41 - 8780 Oostrozebeke

Tel +3256980990 – GSM +32478720104

 


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: problem with init on opensips3.0

Johan De Clercq

Hi,

 

This is solved.   The issue was here that in drouting there was an entry not resolving.   

Net result :

  1. The dialplan did not load, I had to do dp_reload after startup.
  2. The mysql connection in the startup connection timed out.

 

@dev: maybe this should be added in the documentation of the module drouting.  I do agree that it is evident that they should resolve. However, an issue like this is pretty damn hard to troubleshoot.   So a little remark on this in the documentation could help.

 

Best regards,

 

From: Johan De Clercq <[hidden email]>
Sent: Tuesday, June 25, 2019 5:07 PM
To: OpenSIPS users mailling list <[hidden email]>
Subject: Re: [OpenSIPS-Users] problem with init on opensips3.0

 

Yes, they work form command line.

 

Op di 25 jun. 2019 om 16:54 schreef Liviu Chircu <[hidden email]>:

Hi Johan,

Just to be 100% sure it's an OpenSIPS problem, can you confirm either:

* the "db_url" credentials work when used with the "mysql" command-line client,
  from the same source IP
* the same "db_url" works with a 2.4 OpenSIPS, from the same source IP

Regards,

Liviu Chircu
OpenSIPS Developer
http://www.opensips-solutions.com

On 22.06.2019 16:43, johan de clercq wrote:

Hello,

 

Opensips3.0 doesn’t start automatically.    It times out on a remote mysqlconnection.  

 

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:db_mysql:db_mysql_connect: driver error(2003): Can't connect to MySQL server on '10.3.0.81' (110 "Connection timed out")

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:db_mysql:db_mysql_new_connection: initial connect failed

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:db_do_init: could not add connection to the pool

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:domain:domain_db_init: Cannot initialize database connection

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:init_mod: failed to initialize module domain

Jun 22 13:27:09 hendrix /data/opensips/sbin/opensips[1291]: ERROR:core:main: error while initializing modules

 

With 2.4, the problem was not there. Please advice on how I need to fix this.

 

 

 

cid:F3100D46-F00D-4610-87ED-3E91DA790A82

Johan De Clercq, Managing Director
Democon bvba - Ooigemstraat 41 - 8780 Oostrozebeke

Tel +3256980990 – GSM +32478720104

 

 

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users