rtpengine trouble.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

rtpengine trouble.

Johan De Clercq

 

Please find attached

- opensips.cfg,

- opensips.log (rtpengine dbg output only)

- rtpengine (init.d)


pastebin:(http://pastebin.com/ct8rCEwE)

- syslog (contains opensips dbg output )

 

Problem : opensips can’t communicate with rtpengine. (used to work with 1.11 and 2.1 )

Jul 10 16:40:52 webrtc-1 rtpengine[2230]: Failed to properly parse UDP command line '2470_0 d7:command4:pinge' from 82.199.64.147:60185, using fallback RE

 

Opensips is 2.2 from git; rtpengine is latest from git (4.0).

 

Can you please indicate what my problem is or please indicate what logs you need ?

 

Br, Johan.

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

opensips.cfg (9K) Download Attachment
opensips.log (7K) Download Attachment
rtpengine (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: rtpengine trouble.

Bogdan-Andrei Iancu-2
Hi Johan,

So, what you say is that the rtpengine 4.0 is compatible with OpenSIPS 1.11 and 2.1 (using the rtpengine module ??) but not with OpenSIPS 2.2 ?

Regards,
Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com
On 12.07.2016 09:27, Johan De Clercq wrote:

 

Please find attached

- opensips.cfg,

- opensips.log (rtpengine dbg output only)

- rtpengine (init.d)


pastebin:(http://pastebin.com/ct8rCEwE)

- syslog (contains opensips dbg output )

 

Problem : opensips can’t communicate with rtpengine. (used to work with 1.11 and 2.1 )

Jul 10 16:40:52 webrtc-1 rtpengine[2230]: Failed to properly parse UDP command line '2470_0 d7:command4:pinge' from 82.199.64.147:60185, using fallback RE

 

Opensips is 2.2 from git; rtpengine is latest from git (4.0).

 

Can you please indicate what my problem is or please indicate what logs you need ?

 

Br, Johan.


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: rtpengine trouble.

Seven Du
FYI, I installed opensips 2.2 from debian 8 repo and rtpengine from git master a few days ago seems worked.

-- 
Seven Du
Sent with Sparrow

On Thursday, July 14, 2016 at 5:27 PM, Bogdan-Andrei Iancu wrote:

Hi Johan,

So, what you say is that the rtpengine 4.0 is compatible with OpenSIPS 1.11 and 2.1 (using the rtpengine module ??) but not with OpenSIPS 2.2 ?

Regards,
Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com
On 12.07.2016 09:27, Johan De Clercq wrote:

 

Please find attached

- opensips.cfg,

- opensips.log (rtpengine dbg output only)

- rtpengine (init.d)


pastebin:(http://pastebin.com/ct8rCEwE)

- syslog (contains opensips dbg output )

 

Problem : opensips can’t communicate with rtpengine. (used to work with 1.11 and 2.1 )

Jul 10 16:40:52 webrtc-1 rtpengine[2230]: Failed to properly parse UDP command line '2470_0 d7:command4:pinge' from 82.199.64.147:60185, using fallback RE

 

Opensips is 2.2 from git; rtpengine is latest from git (4.0).

 

Can you please indicate what my problem is or please indicate what logs you need ?

 

Br, Johan.


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: rtpengine trouble.

Johan De Clercq
In reply to this post by Bogdan-Andrei Iancu-2
Yes indeed. That is what it seems like.

2016-07-14 11:27 GMT+02:00 Bogdan-Andrei Iancu <[hidden email]>:
Hi Johan,

So, what you say is that the rtpengine 4.0 is compatible with OpenSIPS 1.11 and 2.1 (using the rtpengine module ??) but not with OpenSIPS 2.2 ?

Regards,
Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com
On 12.07.2016 09:27, Johan De Clercq wrote:

 

Please find attached

- opensips.cfg,

- opensips.log (rtpengine dbg output only)

- rtpengine (init.d)


pastebin:(http://pastebin.com/ct8rCEwE)

- syslog (contains opensips dbg output )

 

Problem : opensips can’t communicate with rtpengine. (used to work with 1.11 and 2.1 )

Jul 10 16:40:52 webrtc-1 rtpengine[2230]: Failed to properly parse UDP command line '2470_0 d7:command4:pinge' from 82.199.64.147:60185, using fallback RE

 

Opensips is 2.2 from git; rtpengine is latest from git (4.0).

 

Can you please indicate what my problem is or please indicate what logs you need ?

 

Br, Johan.


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: rtpengine trouble.

Johan De Clercq
Yesterday I solved the issue by changing the -u parameter of rtpengine to --listen-ng.
Now it works as it should.

Maybe it's a good idea to change the tutorial on webrtc 2.2 as the issue is non-trivial to find.

Best regards,

2016-07-14 15:33 GMT+02:00 Johan De Clercq <[hidden email]>:
Yes indeed. That is what it seems like.

2016-07-14 11:27 GMT+02:00 Bogdan-Andrei Iancu <[hidden email]>:
Hi Johan,

So, what you say is that the rtpengine 4.0 is compatible with OpenSIPS 1.11 and 2.1 (using the rtpengine module ??) but not with OpenSIPS 2.2 ?

Regards,
Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com
On 12.07.2016 09:27, Johan De Clercq wrote:

 

Please find attached

- opensips.cfg,

- opensips.log (rtpengine dbg output only)

- rtpengine (init.d)


pastebin:(http://pastebin.com/ct8rCEwE)

- syslog (contains opensips dbg output )

 

Problem : opensips can’t communicate with rtpengine. (used to work with 1.11 and 2.1 )

Jul 10 16:40:52 webrtc-1 rtpengine[2230]: Failed to properly parse UDP command line '2470_0 d7:command4:pinge' from 82.199.64.147:60185, using fallback RE

 

Opensips is 2.2 from git; rtpengine is latest from git (4.0).

 

Can you please indicate what my problem is or please indicate what logs you need ?

 

Br, Johan.


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: rtpengine trouble.

Răzvan Crainea-2

Hi, Jonah!

Thanks for debugging this. Unfortunately I've never started rtpengine without the -n/--listen-ng parameter, so I've never hit this issue.

However, I think the report was initially bogus, because there are no changes in the rtpengine module from 2.1 (in 1.11 it doesn't even exist), so the two versions should behave the same. This made me look into a different direction.

I've now added a note in the tutorial at the listening parameter[1].

[1] http://www.opensips.org/Documentation/Tutorials-WebSocket-2-2#toc3

Best regards,

Răzvan Crainea
OpenSIPS Solutions
www.opensips-solutions.com
On 07/18/2016 09:48 AM, Johan De Clercq wrote:
Yesterday I solved the issue by changing the -u parameter of rtpengine to --listen-ng.
Now it works as it should.

Maybe it's a good idea to change the tutorial on webrtc 2.2 as the issue is non-trivial to find.

Best regards,

2016-07-14 15:33 GMT+02:00 Johan De Clercq <[hidden email]>:
Yes indeed. That is what it seems like.

2016-07-14 11:27 GMT+02:00 Bogdan-Andrei Iancu <[hidden email]>:
Hi Johan,

So, what you say is that the rtpengine 4.0 is compatible with OpenSIPS 1.11 and 2.1 (using the rtpengine module ??) but not with OpenSIPS 2.2 ?

Regards,
Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com
On 12.07.2016 09:27, Johan De Clercq wrote:

 

Please find attached

- opensips.cfg,

- opensips.log (rtpengine dbg output only)

- rtpengine (init.d)


pastebin:(http://pastebin.com/ct8rCEwE)

- syslog (contains opensips dbg output )

 

Problem : opensips can’t communicate with rtpengine. (used to work with 1.11 and 2.1 )

Jul 10 16:40:52 webrtc-1 rtpengine[2230]: Failed to properly parse UDP command line '2470_0 d7:command4:pinge' from 82.199.64.147:60185, using fallback RE

 

Opensips is 2.2 from git; rtpengine is latest from git (4.0).

 

Can you please indicate what my problem is or please indicate what logs you need ?

 

Br, Johan.


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users





_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users