set_count in opensips 1.8.2

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

set_count in opensips 1.8.2

jay1017
Hi All,
Just upgraded to opensips 1.8.2 and it wont start since I have used set_count function in the script. It gives an error:
 unknown command <set_count>, missing loadmodule?
I have the module cfgutils loaded. Guess it is a problem in 1.8.2.

--- Jayesh

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: set_count in opensips 1.8.2

Vlad Paiu
Hello,

There was a bug in the set_count function, and only fix what to slightly change the prototype of the function.
If the counted pvar had 0 elements, the function would return 0, which would lead to stopping the script.

The new prototype is described at http://www.opensips.org/html/docs/modules/1.8.x/cfgutils#id250444

Regards,
Vlad Paiu
OpenSIPS Developer
http://www.opensips-solutions.com 

On 11/08/2012 02:32 PM, Jayesh Nambiar wrote:
Hi All,
Just upgraded to opensips 1.8.2 and it wont start since I have used set_count function in the script. It gives an error:
 unknown command <set_count>, missing loadmodule?
I have the module cfgutils loaded. Guess it is a problem in 1.8.2.

--- Jayesh
_______________________________________________ Users mailing list [hidden email] http://lists.opensips.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users