Quantcast

tls_mgm module ERROR

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

tls_mgm module ERROR

Dragomir Haralambiev
Hello,

I try to start opensips with tls_mgm module and receive follow errors:

Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: WARNING:tls_mgm:mod_init: disabling compression due ZLIB problems
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: INFO:tls_mgm:check_for_krb: KRB5 cipher KRB5-IDEA-CBC-SHA found
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: ERROR:tls_mgm:mod_init: compiled agaist an openssl with kerberos, but run with one with kerberos
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: ERROR:core:init_mod: failed to initialize module tls_mgm

How must to compile Opensips to run without errors?

Regards,
Dragomir

_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: tls_mgm module ERROR

Razvan Crainea-3
Hi, Dragomir!

What library did you compile against (libssl-dev version) and what is the runtime library you are using?

Best regards,
Răzvan Crainea
OpenSIPS Solutions
www.opensips-solutions.com
On 04/05/2017 03:19 PM, Dragomir Haralambiev wrote:
Hello,

I try to start opensips with tls_mgm module and receive follow errors:

Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: WARNING:tls_mgm:mod_init: disabling compression due ZLIB problems
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: <a class="moz-txt-link-freetext" href="INFO:tls_mgm:check_for_krb">INFO:tls_mgm:check_for_krb: KRB5 cipher KRB5-IDEA-CBC-SHA found
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: ERROR:tls_mgm:mod_init: compiled agaist an openssl with kerberos, but run with one with kerberos
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: ERROR:core:init_mod: failed to initialize module tls_mgm

How must to compile Opensips to run without errors?

Regards,
Dragomir


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: tls_mgm module ERROR

Dragomir Haralambiev
rpm -qa |grep ssl

openssl-1.0.1e-60.el7_3.1.x86_64
openssl-libs-1.0.1e-60.el7_3.1.x86_64
mod_ssl-2.4.6-45.el7.centos.x86_64
openssl-devel-1.0.1e-60.el7_3.1.x86_64


2017-04-06 19:16 GMT+03:00 Răzvan Crainea <[hidden email]>:
Hi, Dragomir!

What library did you compile against (libssl-dev version) and what is the runtime library you are using?

Best regards,
Răzvan Crainea
OpenSIPS Solutions
www.opensips-solutions.com
On 04/05/2017 03:19 PM, Dragomir Haralambiev wrote:
Hello,

I try to start opensips with tls_mgm module and receive follow errors:

Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: WARNING:tls_mgm:mod_init: disabling compression due ZLIB problems
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: INFO:tls_mgm:check_for_krb: KRB5 cipher KRB5-IDEA-CBC-SHA found
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: ERROR:tls_mgm:mod_init: compiled agaist an openssl with kerberos, but run with one with kerberos
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: ERROR:core:init_mod: failed to initialize module tls_mgm

How must to compile Opensips to run without errors?

Regards,
Dragomir


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users



_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: tls_mgm module ERROR

Dragomir Haralambiev
Hello,

I update opensips 2.2 from yum.

I continue  to receive follow ERRORS:

Apr  9 22:13:28 dev /usr/local/sbin/opensips[31161]: INFO:tls_mgm:mod_init: initializing TLS protocol
Apr  9 22:13:28 dev /usr/local/sbin/opensips[31161]: WARNING:tls_mgm:mod_init: disabling compression due ZLIB problems
Apr  9 22:13:29 dev /usr/local/sbin/opensips[31161]: INFO:tls_mgm:check_for_krb: KRB5 cipher KRB5-IDEA-CBC-SHA found
Apr  9 22:13:29 dev /usr/local/sbin/opensips[31161]: ERROR:tls_mgm:mod_init: compiled agaist an openssl with kerberos, but run with one with kerberos
Apr  9 22:13:29 dev /usr/local/sbin/opensips[31161]: ERROR:core:init_mod: failed to initialize module tls_mgm
Apr  9 22:13:29 dev /usr/local/sbin/opensips[31161]: ERROR:core:main: error while initializing modules

I have installed :

openssl-devel-1.0.1e-60.el7_3.1.x86_64
krb5-libs-1.14.1-27.el7_3.x86_64
krb5-devel-1.14.1-27.el7_3.x86_64

What I do to start Opensips with tls_mgm?


Best regards:
Dragomir


2017-04-06 23:56 GMT+03:00 Dragomir Haralambiev <[hidden email]>:
rpm -qa |grep ssl

openssl-1.0.1e-60.el7_3.1.x86_64
openssl-libs-1.0.1e-60.el7_3.1.x86_64
mod_ssl-2.4.6-45.el7.centos.x86_64
openssl-devel-1.0.1e-60.el7_3.1.x86_64


2017-04-06 19:16 GMT+03:00 Răzvan Crainea <[hidden email]>:
Hi, Dragomir!

What library did you compile against (libssl-dev version) and what is the runtime library you are using?

Best regards,
Răzvan Crainea
OpenSIPS Solutions
www.opensips-solutions.com
On 04/05/2017 03:19 PM, Dragomir Haralambiev wrote:
Hello,

I try to start opensips with tls_mgm module and receive follow errors:

Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: WARNING:tls_mgm:mod_init: disabling compression due ZLIB problems
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: INFO:tls_mgm:check_for_krb: KRB5 cipher KRB5-IDEA-CBC-SHA found
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: ERROR:tls_mgm:mod_init: compiled agaist an openssl with kerberos, but run with one with kerberos
Apr  5 15:14:05 dev /usr/local/sbin/opensips[2628]: ERROR:core:init_mod: failed to initialize module tls_mgm

How must to compile Opensips to run without errors?

Regards,
Dragomir


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users




_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users
Loading...