upgrade to 1.5 - module versions are mixed

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

upgrade to 1.5 - module versions are mixed

slophoo
after upgrading to 1.5, i now get this error when running opensips start
root@sfsip:/etc/init.d# opensips start
Mar 24 18:24:53 [4389] DBG:core:yyparse: loading module //lib/opensips/modules/signaling.so
Mar 24 18:24:53 [4389] ERROR:core:version_control: module version mismatch for //lib/opensips/modules/signaling.so; core: opensips 1.4.4-notls (i386/linux); module: opensips 1.5.0-notls (i386/linux)
root@sfsip:/etc/init.d#

I can tell that it is still starting the 1.4 opensips core and not happy with the new 1.5 modules, but I cannot figure out why/where it is and how to force 1.5 to start.  To install I ran

make prefix=/ all
make prefix=/ install

Or as an alternative to this question, can anyone tell me how to "uninstall" 1.5 so that i can go back?  I may have jumped the gun.
Reply | Threaded
Open this post in threaded view
|

Re: upgrade to 1.5 - module versions are mixed

Bogdan-Andrei Iancu
Hi,

for sure you are loading the old module (from 1.4 version). Check if the
module dir is properly set (be carefull at lib / lib64 differences )

Regards,
Bogdan

slophoo wrote:

> after upgrading to 1.5, i now get this error when running opensips
> start root@sfsip:/etc/init.d# opensips start Mar 24 18:24:53 [4389]
> DBG:core:yyparse: loading module //lib/opensips/modules/signaling.so
> Mar 24 18:24:53 [4389] ERROR:core:version_control: module version
> mismatch for //lib/opensips/modules/signaling.so; core: opensips
> 1.4.4-notls (i386/linux); module: opensips 1.5.0-notls (i386/linux)
> root@sfsip:/etc/init.d# I can tell that it is still starting the 1.4
> opensips, but I cannot figure out why/where it is and how to force 1.5
> to start. To install I ran make prefix=/ all make prefix=/ install Or
> as an alternative to this question, can anyone tell me how to
> "uninstall" 1.5 so that i can go back? I may have jumped the gun.
> ------------------------------------------------------------------------
> View this message in context: upgrade to 1.5 - module versions are
> mixed
> <http://n2.nabble.com/upgrade-to-1.5---module-versions-are-mixed-tp2530005p2530005.html>
> Sent from the OpenSIPS - Users mailing list archive
> <http://n2.nabble.com/OpenSIPS---Users-f1449235.html> at Nabble.com.
> ------------------------------------------------------------------------
>
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.opensips.org/cgi-bin/mailman/listinfo/users
>  


_______________________________________________
Users mailing list
[hidden email]
http://lists.opensips.org/cgi-bin/mailman/listinfo/users